Cyberduck Mountain Duck CLI

#9792 new defect

Uploads not triggered for filename with quotes

Reported by: rkin005 Owned by: yla
Priority: normal Milestone:
Component: core Version: 5.2.2
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows 10

Description (last modified by rkin005)

When I drag & drop a file from windows explorer onto the Cyberduck window it doesn't start an upload or show any message. It shows the cursor and window highlight when I drag the file over and just before I release, i.e. it looks normal, it just never opens the Transfer window or starts a transfer. Cyberduck is open to an S3 bucket to which I have full control. This used to work fine in the past. Are there any log files I can check to understand what's going wrong? The Log Drawer doesn't show any output when I perform this action.

It also wasn't working for me in this scenario:

  • shift-right-click on file in windows explorer > Copy as Path
  • click the Upload toolbar button
  • paste full path & filename into the Choose box and click Choose

The Choose dialog would close but no action would be performed. If instead I do the same steps BUT remove the leading and trailing double-quotes from the file path then it works fine. Perhaps when you drag-and-drop a file from Explorer it wraps the path name with quotes, and this is why it doesn't work with drag-and-drop?

I have version 5.2.3 (21496) but it's not available in the Version dropdown

NB: this isn't a new problem in 5.2.3; I upgraded to 5.2.3 because I had this problem with and I was hoping it was fixed in latest version. I'm pretty sure (but not 100%) that this wasn't a problem in my earlier version which was

Change History (10)

comment:1 Changed on Dec 22, 2016 at 2:57:36 PM by rkin005

  • Description modified (diff)

comment:2 Changed on Jan 10, 2017 at 1:29:11 PM by dkocher

  • Milestone set to 6.0
  • Owner set to yla
  • Summary changed from Uploads not triggered when dragging & dropping onto Cyberduck (problem with quoted path?) to Uploads not triggered for filename with quotes

comment:3 Changed on Jan 10, 2017 at 1:29:46 PM by dkocher

Thanks for the issue report. Please attach the file cyberduck.log in the application support directory.

comment:4 Changed on Jan 11, 2017 at 8:33:37 AM by dkocher

  • Milestone changed from 6.0 to 5.3

Milestone renamed

comment:5 Changed on Jan 11, 2017 at 3:32:21 PM by dkocher

  • Milestone changed from 5.3 to 6.0

Ticket retargeted after milestone closed

comment:6 Changed on Jan 18, 2017 at 5:09:09 PM by rkin005

I'm now using 5.3.2

Log file is empty.

I emptied the file before relaunching CyberDuck, repeated the two types of uploads (drag & drop and right-click > upload including quotes in path) and nothing in the log file at all. I then tried the upload using right-click > upload and not wrapping the filename in quotes and the upload worked but again there's nothing in the log file.

comment:7 Changed on May 5, 2017 at 1:45:11 PM by dkocher

  • Milestone changed from 6.0 to 7.0

Ticket retargeted after milestone closed

comment:8 Changed on Jan 13, 2018 at 8:52:56 AM by Vh1F8t3vYxtu

You might be interested by #10191, which describes a related issue:

  • on Google Drive
  • with non-empty folders
  • whose name contains a single quote
Last edited on Jan 13, 2018 at 9:01:33 AM by Vh1F8t3vYxtu (previous) (diff)

comment:9 Changed on Sep 4, 2018 at 10:36:43 AM by dkocher

#10191 closed as duplicate.

comment:10 Changed on Sep 4, 2018 at 10:36:54 AM by dkocher

  • Milestone 7.0 deleted
  • Severity changed from major to normal
Note: See TracTickets for help on using tickets.
swiss made software