Cyberduck Mountain Duck CLI

#9819 closed defect (fixed)

Failure setting attributes for uploaded files with temporary filename option enabled

Reported by: Moonwatcher Owned by: Moonwatcher
Priority: high Milestone: 5.3.4
Component: ftp Version: 5.3.3
Severity: major Keywords: timestamp date modified
Cc: Architecture: Intel
Platform: Mac OS X 10.11

Description

Version 5.3.3 (23221) Regardless of how Timestamps preferences are selected, when I place file on server, the modified date always changes to Today. This is not helpful. For example, if I replace a more recently modified file on the server with an older file, I want to see its modified date, and not today's because the file on the server hasn't been modified, just replaced. This used to work "as expected."

Attachments (3)

Screen Shot 2017-01-21 at 12.35.05.png (56.5 KB) - added by Moonwatcher on Jan 21, 2017 at 12:37:07 PM.
Screenshot of preferences
Screen Shot 2017-01-23 at 08.32.57.png (208.1 KB) - added by Moonwatcher on Jan 23, 2017 at 8:56:17 AM.
Screenshot of Cyberduck and Finder windows
log.rtf (9.6 KB) - added by Moonwatcher on Jan 23, 2017 at 3:03:50 PM.
Log of Transfer window

Download all attachments as: .zip

Change History (18)

Changed on Jan 21, 2017 at 12:37:07 PM by Moonwatcher

Screenshot of preferences

comment:1 Changed on Jan 22, 2017 at 7:34:19 PM by dkocher

  • Version changed from 5.3.2 to 5.3.3

comment:2 Changed on Jan 23, 2017 at 8:55:11 AM by Moonwatcher

  • Owner set to Moonwatcher
  • Status changed from new to assigned

Changed on Jan 23, 2017 at 8:56:17 AM by Moonwatcher

Screenshot of Cyberduck and Finder windows

comment:3 Changed on Jan 23, 2017 at 9:38:27 AM by dkocher

What protocol do you use to connect to the server?

comment:4 Changed on Jan 23, 2017 at 12:01:45 PM by Moonwatcher

Plain FTP.

comment:5 Changed on Jan 23, 2017 at 12:22:58 PM by dkocher

  • Component changed from core to ftp
  • Milestone set to 6.0
  • Summary changed from modified date not honoured to Modification date changed when replacing file

comment:6 Changed on Jan 23, 2017 at 12:57:38 PM by dkocher

Please post the transcript from the log drawer of the Transfers window. Choose ⌘-L on Mac.

comment:7 Changed on Jan 23, 2017 at 1:25:10 PM by Moonwatcher

Here you go. Would prefer if file wasn't made public.

comment:8 Changed on Jan 23, 2017 at 1:29:43 PM by dkocher

Looks like the transcript from the browser window. Can you double check to open the transcript from the Transfers window prior restarting a transfer.

comment:9 Changed on Jan 23, 2017 at 3:02:48 PM by Moonwatcher

That was blank, so I Cmd+L and sent one I saw. Here is one from blank Transfers window after uploading file.

Changed on Jan 23, 2017 at 3:03:50 PM by Moonwatcher

Log of Transfer window

comment:10 Changed on Jan 23, 2017 at 3:09:25 PM by dkocher

Thanks for the transcript where we can see the source of the error.

MFMT 20170123145833 /public_html/monomania/templates/template_theproject/header.tpl-5Eodd7JH
550 utime(/public_html/monomania/templates/template_theproject/header.tpl-5Eodd7JH): No such file or directory

comment:11 Changed on Jan 23, 2017 at 3:41:10 PM by Moonwatcher

If you mean the error is because no file exists, that's not true. See previous screenshots of file in Finder and when transferred to server. The files are being found and replaced, problem is the modified date on the server isn't being kept and changed to today's date. I think the problem is when files are replaced, Cyberduck thinks file is being modified, it's not. The data in the file hasn't changed, so file shouldn't be marked as *modified* regardless of whether it's being uploaded or downloaded (unless you tick off the preferences to keep timestamps).

comment:12 Changed on Jan 25, 2017 at 10:24:44 AM by dkocher

As a workaround, uncheck the option Preferences → Transfers → Uploads → Upload with temporary filename.

comment:13 Changed on Jan 25, 2017 at 10:27:33 AM by dkocher

  • Summary changed from Modification date changed when replacing file to Failure setting attributes for uploaded files with temporary filename option enabled

comment:14 Changed on Jan 25, 2017 at 10:31:19 AM by dkocher

  • Milestone changed from 6.0 to 5.3.4

comment:15 Changed on Jan 25, 2017 at 2:40:07 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r37956.

Note: See TracTickets for help on using tickets.
swiss made software