Cyberduck Mountain Duck CLI

#9821 closed defect (fixed)

DNS lookup failure

Reported by: sthiell Owned by: dkocher
Priority: normal Milestone: 5.3.4
Component: sftp Version: 5.3.3
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

On a brand new installation, I got the following error in a window when I try to create a new connection (note: I tried with several hostnames and even IPs):

Connection failed

DNS lookup for %h failed. DNS is the network service that translates a server name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing access to the network.


This makes SFTP unusable for me. The "%h" thing seems to be a problem of string formatting. The other protocols don't seem to be affected as far as I know.

Note: I cannot choose 5.3.3 in the Version popup on trac.

Attachments (1)

Screen Shot 2017-01-21 at 10.24.07 AM.png (152.8 KB) - added by sthiell on Jan 21, 2017 at 6:26:25 PM.
image of the error when using SFTP

Download all attachments as: .zip

Change History (9)

Changed on Jan 21, 2017 at 6:26:25 PM by sthiell

image of the error when using SFTP

comment:1 Changed on Jan 21, 2017 at 6:39:15 PM by sthiell

  • Version set to 5.3

FYI I also got a similar error with Mountain Duck that I just wanted to give a try... but the %h is replaced by 0.000000000

comment:2 Changed on Jan 23, 2017 at 9:40:45 AM by dkocher

I cannot reproduce the error nor the formatting failure in the DNS lookup failure message. Can you please open Console.app, filter for “Cyberduck” in the upper right search field with “system.log” selected in the left pane. Then choose File → Save Copy As…” to save the log file and attach it to your email reply. 

comment:3 Changed on Jan 23, 2017 at 9:40:51 AM by dkocher

  • Component changed from core to sftp
  • Owner set to dkocher

comment:4 Changed on Jan 23, 2017 at 9:41:49 AM by dkocher

Can you also move aside your ~/.ssh/config file as a possible source of the failure.

comment:5 Changed on Jan 23, 2017 at 12:27:06 PM by dkocher

  • Milestone set to 6.0
  • Summary changed from SFTP unusable with 5.3.3 to DNS lookup failure

comment:6 Changed on Jan 23, 2017 at 12:27:16 PM by dkocher

  • Version changed from 5.3 to 5.3.3

comment:7 Changed on Jan 23, 2017 at 12:27:27 PM by dkocher

  • Description modified (diff)

comment:8 Changed on Jan 30, 2017 at 3:49:14 PM by dkocher

  • Milestone changed from 6.0 to 5.3.4
  • Resolution set to fixed
  • Status changed from new to closed

In r38015 and r38019. Please update to the latest snapshot build available.

Note: See TracTickets for help on using tickets.
swiss made software