Cyberduck Mountain Duck CLI

#9877 closed defect (thirdparty)

com.liferay.nativity.control.win.WindowsNativityControlImpl - Address already in use: JVM_Bind

Reported by: johnaparker Owned by:
Priority: high Milestone:
Component: core Version: 5.3.9
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

When I first installed MountainDuck (MD) I was asked if using registering a real license or doing a trial. As we were having issues getting our five seat license purchased I answered trial. The install completed and I rebooted my Windows Server 2008 R2 VM and tried invoking MD but no UI window appeared. I tried a number of times, including after killing the MD process that I found running.

We then got our license but as I could get no window I obviously could not install it. I then did an uninstall of MD and tried installing again (rebooting when indicated), but this time no request for a license was presented. I wonder if this might be due to residual files or registry settings?) When I tried then to invoke MD the behavior was the same: No UI window.

Following suggestions on the MD web pages I checked the mountainduck.log (attached) and saw that at each attempted start a Java fault was logged indicating:

2017-03-10 18:00:03,581 [Thread-2] ERROR com.liferay.nativity.control.win.WindowsNativityControlImpl - Address already in use: JVM_Bind
java.net.BindException: Address already in use: JVM_Bind

I saw on the web that some Tomcat containers experienced the same issue which turned out to be port contention. I followed the recommended suggestions but found no process bound to port :80. I did see that my Chrome browser had grabbed :443 so I killed it and tried again. Same result. I searched my system and found the %AppData%\Cyberduck\Profiles\Rackspace US.cyberduckprofile which was configured with:

<key>Default Port</key> <string>443</string>

Having no idea if I should or should not adjust this, I did (to use port 8443), but with no luck.

It's LIKELY to matter so let me point out that the Windows VMs we will need to use MountainDuck on live on 10-space IP VPN with its OWN firewall and ACL rules isolated behind our Server Farm firewall. A number of ports are open to the external world including 80, 8080, 443 and 8443, and we can request additional firewall rules as required, but obviously only if we know what we need.

Please advise on what we need to do to make MountainDuck functional.

Also... PLEASE NOTE that I have no idea if the "Component" or "Version" detail provided here is accurate. I can only attest to the Windows installer I ran was named: Mountain Duck Installer-1.7.2.6307.exe

Attachments (1)

mountainduck.log (38.7 KB) - added by johnaparker on Mar 11, 2017 at 12:51:16 PM.
MountanDuck Log

Download all attachments as: .zip

Change History (4)

Changed on Mar 11, 2017 at 12:51:16 PM by johnaparker

MountanDuck Log

comment:1 Changed on Mar 11, 2017 at 12:56:14 PM by johnaparker

  • Description modified (diff)

comment:2 Changed on Mar 12, 2017 at 10:01:16 AM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

Can you please forward this to [support@…].

comment:3 Changed on Mar 12, 2017 at 10:01:28 AM by dkocher

  • Description modified (diff)
Note: See TracTickets for help on using tickets.
swiss made software