Cyberduck Mountain Duck CLI

#9887 closed defect (worksforme)

Request signature error accessing bucket

Reported by: Martinl Owned by: dkocher
Priority: normal Milestone: 5.4.1
Component: s3 Version: 5.4
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

As the title implies, I can access an Amazon S3 bucket on Windows 10, but NOT on OSX 10.10.5. I get this error message:

'''Listing directory p5-select-b3 failed.''' The request signature we calculated does not match the signature you provided. Check your key and signing method. Please contact your web hosting service provider for assistance.

See the provided still.

I also tried another app from Eltima called Commander One. Identical issue

The operation couldn’t be completed. (The request signature we calculated does not match the signature you provided. Check your key and signing method. error -1.)

However, with the exact same sign in details I am able to access this bucket on a Windows 10 PC.

Thanks in advance for your help! Regards, Martin Landsburg

PS: will there be support for Amazon Cloud drive in the future?

Attachments (1)

Screenshot 2017-03-07 12.23.51.jpg (73.1 KB) - added by Martinl on Mar 17, 2017 at 5:09:55 AM.
screenshot

Download all attachments as: .zip

Change History (7)

Changed on Mar 17, 2017 at 5:09:55 AM by Martinl

screenshot

comment:1 Changed on Mar 17, 2017 at 9:39:55 AM by dkocher

  • Component changed from core to s3
  • Description modified (diff)
  • Owner set to dkocher

comment:2 Changed on Mar 17, 2017 at 9:40:11 AM by dkocher

  • Summary changed from I can access S3 bucket on Windows 10 but not on OSX 10.10.5 to Request signature error accessing bucket

comment:3 Changed on Mar 17, 2017 at 9:40:52 AM by dkocher

See #5858 for Cloud Drive.

comment:4 Changed on Mar 17, 2017 at 9:41:10 AM by dkocher

  • Description modified (diff)

comment:5 Changed on Mar 17, 2017 at 9:42:21 AM by dkocher

  • Milestone set to 6.0
  • Status changed from new to assigned

Can you create temporary read-only access credentials for the bucket with IAM and send us the access key to support@… that will allow us to reproduce the issue? In what region is the bucket located?

comment:6 Changed on Apr 3, 2017 at 7:31:04 PM by dkocher

  • Milestone changed from 6.0 to 5.4.1
  • Resolution set to worksforme
  • Status changed from assigned to closed

We cannot reproduce this issue.

Note: See TracTickets for help on using tickets.
swiss made software