Cyberduck Mountain Duck CLI

#9895 closed defect (thirdparty)

Uploads to vault on B2 fail with Sha1 did not match data received

Reported by: ftischhauser Owned by: dkocher
Priority: normal Milestone: 6.4.4
Component: cryptomator Version: Nightly Build
Severity: normal Keywords:
Cc: b@… Architecture:
Platform: Windows 10

Description (last modified by dkocher)

I have created an encrypted vault on B2 using the latest nightly build. All uploads fail with the error message: Sha1 did not match data received.

Uploading the same files to a regular vault works fine.

Thanks for looking into this!

Attachments (1)

Screen Shot 2018-03-02 at 7.38.27 pm.png (306.7 KB) - added by dkocher on Mar 2, 2018 at 12:12:09 PM.

Download all attachments as: .zip

Change History (17)

comment:1 Changed on Mar 24, 2017 at 8:58:37 PM by dkocher

  • Milestone set to 6.0
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed on Apr 11, 2017 at 12:02:00 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r38566.

comment:3 Changed on Mar 2, 2018 at 11:40:56 AM by balupton

  • Resolution fixed deleted
  • Status changed from closed to reopened

Just ran into this then: https://www.dropbox.com/s/6yiqba8xvpiywgg/Screen%20Shot%202018-03-02%20at%207.38.27%20pm.png?dl=0

Running CyberDuck Version 6.4.3 (27644) on MacOS 10.13.3 (17D102)

How shall we debug?

comment:4 Changed on Mar 2, 2018 at 11:41:10 AM by balupton

  • Cc b@… added

comment:5 Changed on Mar 2, 2018 at 11:56:33 AM by dkocher

  • Summary changed from Uploads to Encrypted Vault on Backblaze B2 Fail to Uploads to vault on B2 fail with Sha1 did not match data received

comment:6 Changed on Mar 2, 2018 at 11:56:40 AM by dkocher

  • Milestone changed from 6.0 to 6.4.4

comment:7 Changed on Mar 2, 2018 at 12:12:21 PM by dkocher

  • Description modified (diff)

comment:8 Changed on Mar 2, 2018 at 12:15:23 PM by dkocher

  • Description modified (diff)

comment:9 Changed on Mar 2, 2018 at 12:15:32 PM by dkocher

  • Description modified (diff)

comment:10 Changed on Mar 2, 2018 at 12:29:23 PM by balupton

  • Platform changed from Windows 10 to macOS 10.13

comment:11 Changed on Mar 2, 2018 at 12:31:12 PM by balupton

I've got the dialog still open. I am not sure what "Continue" and "Always" mean here.

Intuitively I am after a "Retry" button to try again, or a "Cleanup" button to remove the corrupted file for a later try.

Is there a log file written anywhere that I can include in this issue? Thanks!

comment:12 follow-up: Changed on Mar 5, 2018 at 8:47:07 PM by dkocher

  • Platform changed from macOS 10.13 to Windows 10

I cannot reproduce the issue with a 346.8MB upload. Can you try again and see if you get the same error again? Possibly there was indeed an issue with saving the file in B2 causing a checksum failure.

comment:13 Changed on Mar 6, 2018 at 5:48:25 AM by balupton

Yeah, it's happened one out of two times that I've tried since the "transfer incomplete" fixes landed. The first was about 10gb and worked fine, this one was about 6gb and had this. Both uploads were many different files.

So happy to have this as not cyberduck's issue. However, I am unsure how to proceed when I get this dialog, or a transfer incomplete notification (which still happens sometimes). In this case, what does "continue" or "cancel" even mean? Does "cancel" do any cleanup? Does "continue" reupload the failed part, or just skip it? Naturally - I want either the failed area to be retried or clean up, so that the entire transfer can complete successfully - continue just seems to imply skip, which would "corrupt" my transfer as data is missing or invalid.

Advice on how to proceed when these things occur would be great, as right now there is no meaningful logs or dialogs to know. Perhaps the suggestion in my earlier comment would be helpful: https://trac.cyberduck.io/ticket/9895#comment:11

Thank you!

comment:14 in reply to: ↑ 12 Changed on Mar 6, 2018 at 4:58:05 PM by dkocher

Replying to dkocher:

I cannot reproduce the issue with a 346.8MB upload. Can you try again and see if you get the same error again? Possibly there was indeed an issue with saving the file in B2 causing a checksum failure.

If you have set in Preferences → Connection → Repeat failed networking tasks to automatically retry errors, the file transfer has been retried already. The prompt only allows you to continue transferring the remaining files or cancel the transfer.

comment:15 Changed on Mar 6, 2018 at 4:58:12 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from reopened to closed

comment:16 Changed on Mar 7, 2018 at 1:38:18 AM by balupton

So does cancel delete the corrupted files?

Why would I want to continue without all the data passing?

Is it possible to submit a feature request for my suggestions to that dialog?

Note: See TracTickets for help on using tickets.
swiss made software