Cyberduck Mountain Duck CLI

Opened 12 years ago

Closed 12 years ago

#995 closed defect (fixed)

Symbolic links on local side are not handled properly

Reported by: simonvwade Owned by: dkocher
Priority: highest Milestone:
Component: core Version: 2.7.2
Severity: critical Keywords:
Cc: Architecture:
Platform:

Description

When you download a file and overwrite a file that is a symbolic link on the local machine Cyberduck does something very weird. It should open a file pointer on the symbolic link and the filesystem will handle writing the contents of the file to the location that is referred to by the symbolic link.

Example:

In Terminal:

cd ~/tmp
echo "Hello world" > file.txt
ln -s file.txt link.txt
ls -al

In Cyberduck:

Upload link.txt
Download link.txt

In Terminal:

cd ~/tmp
ls -al

See that file.txt has now become a symbolic link to 'Hello world?' - it's not even a file anymore.

Thanks for a great FTP client!

Simon

Change History (4)

comment:1 Changed 12 years ago by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

This seems to work here without any issues. What is not supported are the old style 'Alias' created in the Finder.app. These will get transferred as zero-sized files. Please reopen with more details (the output of ls -al before and after the transfers) if you can reproduce this issue.

comment:2 Changed 12 years ago by simonvwade

  • Resolution worksforme deleted
  • Status changed from closed to reopened
monty:~/tmp$ echo "Hello world" > file.txt
monty:~/tmp$ ln -s file.txt link.txt
monty:~/tmp$ ls -al
total 16
drwxr-xr-x     4 simonwad  staff   136 Jan 22 10:24 .
drwxr-xr-x   131 simonwad  staff  4454 Jan 22 10:23 ..
-rw-r--r--     1 simonwad  staff    12 Jan 22 10:24 file.txt
lrwxr-xr-x     1 simonwad  staff     8 Jan 22 10:24 link.txt -> file.txt

Uploaded and downloaded link.txt

monty:~/tmp$ ls -al
total 16
drwxr-xr-x     5 simonwad  staff   170 Jan 22 10:26 .
drwxr-xr-x   131 simonwad  staff  4454 Jan 22 10:23 ..
-rw-r--r--     1 simonwad  staff     0 Jan 21 18:25 Hello world?
lrwxr-xr-x     1 simonwad  staff    12 Jan 22 10:26 file.txt -> Hello world?
lrwxr-xr-x     1 simonwad  staff     8 Jan 22 10:24 link.txt -> file.txt

comment:3 Changed 12 years ago by dkocher

Thanks for the updated comment. I can see this now - very weird. Seems to be a problem in java.io.File as this is supposed to resolve symbolic transparently.

comment:4 Changed 12 years ago by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

As of r2773.

Note: See TracTickets for help on using tickets.
swiss made software