Cyberduck Mountain Duck CLI

#9950 closed defect (fixed)

Problem creating directory in encrypted vault over FTP

Reported by: TheBashar Owned by: dkocher
Priority: high Milestone: 6.0.1
Component: ftp Version: Nightly Build
Severity: major Keywords:
Cc: Architecture:
Platform: Windows 10

Description (last modified by dkocher)

I am connecting to an encrypted vault over FTP. I try to create a directory and the operation fails with:

"Cannot create folder [UID]..." where [UID] is the folder hash name.

I see at the bottom of the error popup:

MKDIR /path/to/vault/d/W7/[UID]

In the preceding directory listing, I see there is no "W7" directory. I think Cyberduck is trying to create a nested directory "W7/[UID]" in one command which returns a 550 error. I think Cyberduck needs to issue two separate commands:

MKDIR /path/to/vault/d/W7
MKDIR /path/to/vault/d/W7/[UID]

Attachments (1)

uploadbug.jpg (174.2 KB) - added by TheBashar on May 24, 2017 at 2:41:54 AM.
Failed (incomplete) 0B of 0B upload

Download all attachments as: .zip

Change History (10)

comment:1 Changed on May 23, 2017 at 2:35:58 PM by dkocher

  • Milestone set to 6.0.1
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed on May 23, 2017 at 3:13:12 PM by dkocher

  • Description modified (diff)

comment:3 Changed on May 23, 2017 at 3:14:47 PM by dkocher

I cannot reproduce the error here neither manually nor is our integration test failing for creating directories in a vault. Can you attach the full transcript from the log drawer?

comment:4 Changed on May 23, 2017 at 9:12:07 PM by TheBashar

I can post a screenshot when I get home (~8 hours). In the meantime, may I guess that your test FTP server can create nested directories with one single command (MKDIR /x/y/z) whereas mine can only create one level at a time?

comment:5 Changed on May 24, 2017 at 1:46:29 AM by TheBashar

Hmm... I am unable to immediately reproduce the bug. In my simple tests Cyberduck is correctly issuing separate MKDIR commands. I will try to recall what activities I was doing before I hit the problem yesterday and see if I can recreate the problem. If not, I'll post back here in 24 hours and resolve as invalid or wfm.

Changed on May 24, 2017 at 2:41:54 AM by TheBashar

Failed (incomplete) 0B of 0B upload

comment:6 Changed on May 24, 2017 at 2:42:36 AM by TheBashar

While trying to reproduce the original directory creation failure, I kept running into some upload failure problem. Maybe they are related? I think maybe there is some kind of caching problem or something. Here is what I did:

  • Connected to encrypted vault TEST over FTP
  • Navigated down directories parent/child1/grandchild
  • Uploaded a folder "test1" with ~100 files 0.5-1M in size
  • Navigated into new test1 folder and confirmed files appeared correct
  • Used back navigation to go back up to "grandchild" folder
  • Attempted to upload similar folder "test2"
  • Transfer immediately shows red circle, incomplete status, 0 B of 0 B
  • Tried to upload again, same failed result
  • Tried to upload a single file to "grandchild" folder, same failed result
  • Was able to create "manual" folder in "grandchild" folder
  • Navigated down into new manual folder
  • Was then able to upload "test2" folder into manual folder
  • Tried to upload "test1" folder into manual folder, failed
  • Navigated back up to "grandchild" folder
  • Tried again to upload test2 folder, failed
  • Created another "manual2" folder
  • Navigated into new manual2 folder
  • Was able to upload "test1" folder
  • Was able to re-upload (overwrite) "test1" folder
  • Tried to upload test2 folder, failed
Last edited on May 24, 2017 at 2:57:03 AM by TheBashar (previous) (diff)

comment:7 Changed on May 24, 2017 at 2:44:19 AM by TheBashar

Forgot to add at the end: no errors seen in cyberduck.log and none seen in the log drawer. Last log drawer entries are listing the directory contents and then nothing related to the upload attempts. Also, closing and reopening Cyberduck does not clear out the inability to upload problem.

Last edited on May 24, 2017 at 2:55:48 AM by TheBashar (previous) (diff)

comment:8 Changed on May 24, 2017 at 6:45:47 AM by dkocher

  • Priority changed from normal to high

comment:9 Changed on May 24, 2017 at 2:21:16 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r41103.

Note: See TracTickets for help on using tickets.
swiss made software