Last modified 15 months ago Last modified on 02/18/15 14:35:14

Cyberduck Help / Howto / Browser

List and Outline View

Select View → as List (⌘-1) or View → as Outline (⌘-2) for expandable folders. You can expand and disclose folders using the arrow keys and display the content of the selected/parent folder using Command Down/Up Arrow.

Spring-loaded folders

Spring-loaded folders are a feature that allow you to move a file or even another folder, into a folder deeply nested within several other folders using drag and drop. To enable, choose Preferences → Browser → Use spring-loaded folders when dragging files and adjust the delay for the folder to expand when hovering over with the mouse. Note that spring-loaded folders are only supported in outline view.

Filter

Use the search field (⌘-/) to filer files by name. Only files that match the search string are displayed in the browser. Search is case insensitive.

Sorting

You can sort the file listing by clicking the table column header. Choose View → Column to add more headers such as Kind to allow sorting by file type including folders appearing first in the list.

No local file browser

Why isn't there a local file viewer/two pane interface? That's what Finder.app is for. Use drag and drop (eventually together with Exposé) or Menu File → Upload instead You can also copy files in the Finder.app and then paste them in Cyberduck using Menu Edit → Paste (⌘-V) from Finder. See other upload methods.

Working with files and folders

Edit

You can edit any file on the server using your preferred application. See Edit Files.

Create new folder or file

Use File → New Folder... (⌘-N) or File → New File... (⌘-F) to create a new folder or file on the server.

Move or duplicate files and folders

You can move files in the browser as you would in the Finder.app using drag and drop. Use the modifier key to duplicate files. If connected to the same server, you can also move files between different browser windows.

The following protocols allow duplicating files on the server without downloading and uploading but copying in place:

To move a file, use Edit → Cut (⌘-X) followed by Edit → Paste (⌘-V). To duplicate a file, use Edit → Copy (⌘-C) followed by Edit → Paste (⌘-V).

Copy files and folders to different server

You can copy files between arbitary servers when connected to with two open browser windows. Drag files from one browser to the other to transfer files between servers.

Copy files between servers

Rename a file or folder

Select the file in the browser and press the return or Enter key. Type the new name and press return again to exit the editing mode. You can also rename files by choosing File → Info (⌘-I) or press the Get Info toolbar button. Simply enter the new name in the very top field. The field must loose focus (e.g. by hitting Enter or Tab) to commit the filename change.

Choose File → New Symbolic Link... to create a symbolic link. This is supported on UNIX systems with a SFTP connection and some FTP with SITE SYMLINK extension.

Info Window

Select the file in the browser and choose File → Info (⌘-I) to display detailed attributes of a file in a tool window. It allows to change permissions, manage content distributions for cloud services and settings specific to the Amazon S3 service.

QuickLook

You can toggle Quick Look in a Cyberduck browser for any file using Space Bar. A preview is rendered depending on a Quick Look Plugin available on your system for the given file type. Many file types like different image formats can be previewed with the bundled plugins in OS X and HTML is even rendered in the Quick Look preview panel.

Open or Copy HTTP URL

See bookmark Web URL configuration for HTTP URLs. You can select multiple files to open/copy all URLs.

  • Open Web URL. The Web URL can be found in the File → Open URL menu and as an optional toolbar item in the browser window. Use View → Customize Toolbar... to add the Open in Browser button to your default browser toolbar.
  • Copy Web URL. The Web URL can be found in the Edit → Copy URL menu.

Open in Terminal

Refer to Open in Terminal.

Print browser folder listing

Use the File → Print option where you can open a PDF from the browser listing or print it.

Folder icon badges

Folder icons are badged for particular access permissions.

  • Folder with no permission to access.

  • Folder with read only permissions. Uploading or editing files to this folder is not possible.

  • Drop Folder where you can only upload files to but are not allowed to view its content.

Activity

Use Window → Activity (⌘-0) to to toggle the activity window. It lists the currently running background tasks at the top and all queued activities subsequently.

Transcript

Choose View → Toggle Log Drawer (⌘-L) to open the log drawer. Events are only logged once the drawer is open.

Problems

Special characters such as Umlaute

If characters aren't displayed correctly in the browser, try to change the character encoding used. See View → Text Encoding or edit the bookmark Encoding' 'setting. Try UTF-8 (the default), ISO-8859-1 and Windows-1252.

The folder size isn't displayed correctly

This is not the size of its content but the size of the folder itself. Use File → Info (⌘-I) to calculate the size recursively of all contained files.

Preferences

General → Browser → Save Workspace

Restore browser sessions that were left open when the application was last quit.

General → Browser → Open new browser window on startup

Open new browser window after application launch.

Browser → General → Show Hidden Files

Display files in the browser that start with . and previous revisions (S3). Use View → Show Hidden Files to toggle the mode of a current browser window.

Browser → General → Info window always shows current selection

use only one Info window which updates with the selection change in the browser. If unchecked, open multiple Info windows to compare files.

Hidden Preferences

Adjust the browser font size

A hidden configuration option.

defaults write ch.sudo.cyberduck browser.font.size 18

Duplicate filename format

A hidden configuration option. Define a different format using

defaults write ch.sudo.cyberduck browser.duplicate.format "{0} ({1}){2}"

where the placeholders will be replaced with

  • {0} with the base filename
  • {1} with the timestamp of the file
  • {2} with the extension in the format .extension if present in the original filename.

Warning before renaming or moving files

A hidden configuration option. A confirmation is shown before renaming or moving files.

defaults write ch.sudo.cyberduck browser.move.confirm true

Attachments

swiss made software