Cyberduck Mountain Duck CLI

Changes between Version 20 and Version 21 of help/en/howto/browser


Ignore:
Timestamp:
Sep 2, 2010 11:15:50 AM (10 years ago)
Author:
dkocher
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • help/en/howto/browser

    v20 v21  
    33= [wiki:help/en Cyberduck Help] / [wiki:help/en/howto Howto] / Browser =
    44
     5== Navigation ==
    56=== List and Outline View ===
    6 
    77Select ''View → as List'' or ''View → as Outline'' for expandable folders. You can expand and disclose folders using the arrow keys and display the content of the selected/parent folder using ''Command Down/Up Arrow''.
    88
    99=== Spring-loaded folders ===
    10 
    1110Spring-loaded folders are a feature that allow you to move a file or even another folder, into a folder deeply nested within several other folders using drag and drop. To enable, choose ''Preferences → Browser → Use spring-loaded folders when dragging files'' and adjust the delay for the folder to expand when hovering over with the mouse. Note that spring-loaded folders are only supported in outline view.
    1211
    1312=== Filter ===
    14 
    1513Use the search field (''Command-/'') to filer files by name. Only files that match the search string are displayed in the browser.  Search is case insensitive.
    1614
     15
     16== Working with files and folders ==
    1717=== Create new folder or file ===
    1818Use ''File → New Folder...'' or ''File → New File...'' to create a new folder or file on the server.
    1919
    2020=== Move or duplicate files ===
    21 
    2221You can move files in the browser as you would in the Finder.app. Use the alt modifier key to duplicate files. If connected to the same server, you can also move files between different browser windows.
    2322
     
    2524
    2625=== Rename a file or folder ===
    27 
    2826Select the file in the browser and press the return or ''Enter key''. Type the new name and press return again to exit the editing mode. You can also rename files by choosing ''File → Info'' or press the Get [wiki:help/en/howto/info Info] toolbar button. Simply enter the new name in the very top field. The field must loose focus (e.g. by hitting Enter or Tab) to commit the filename change.
    2927
     
    3129
    3230=== Info Window ===
    33 
    3431Select the file in the browser and choose ''File → Info'' to display [wiki:help/en/howto/info detailed attributes] of a file in a tool window. It allows to change permissions, manage content distributions for cloud services and settings specific to the Amazon [wiki:help/en/howto/s3 S3] service.
    3532
    3633=== QuickLook ===
    37 
    3834You can toggle Quick Look in a Cyberduck browser for any file using ''Space Bar''. A preview is rendered depending on a Quick Look Plugin available on your system for the given file type. Many file types like different image formats can be previewed with the bundled plugins in OS X and HTML is even rendered in the Quick Look preview panel.
    3935
    4036=== Open Web URL ===
    41 
    4237Open the corresponding web address of a file selected in Cyberduck with your default web browser. For this feature to work, you have to specify a reasonable default path in your bookmark (e.g. {{{/home/dkocher/public_html/}}}) which must be the directory accessed by the web server as your document root. Using an Apache webserver, this is the {{{DocumentRoot}}} directive. Also in the bookmark setting, you can edit the Web URL which allows you to enter the HTTP URL of the webserver using a different hostname. The ''Open Web URL'' can be found in the ''File'' Menu and as an optional toolbar item in the browser window.
    4338