Cyberduck Mountain Duck CLI

Version 17 (modified by dkocher, on Jan 12, 2010 at 11:41:56 AM) (diff)

--

Cyberduck Help / Howto / Browser

List and Outline View

Select View → as List or View → as Outline for expandable folders. You can expand and disclose folders using the arrow keys and display the content of the selected/parent folder using Command Down/Up Arrow.

Spring-loaded folders

Spring-loaded folders are a feature that allow you to move a file or even another folder, into a folder deeply nested within several other folders using drag and drop. To enable, choose Preferences → Browser → Use spring-loaded folders when dragging files and adjust the delay for the folder to expand when hovering over with the mouse. Note that spring-loaded folders are only supported in outline view.

Filter

Use the search field (Command-/) to filer files by name. Only files that match the search string are displayed in the browser. Search is case insensitive.

Create new folder or file

Use File → New Folder... or File → New File... to create a new folder or file on the server.

Move or duplicate files

You can move files in the browser as you would in the Finder.app. Use the alt modifier key to duplicate files. If connected to the same server, you can also move files between different browser windows.

source:trunk/www/help/images/move.png

Info Window

Select the file in the browser and choose File → Info to display detailed attributes of a file in a tool window. It allows to change permissions, manage content distributions for cloud services and settings specific to the Amazon S3 service.

QuickLook

You can toggle Quick Look in a Cyberduck browser for any file using Space Bar. A preview is rendered depending on a Quick Look Plugin available on your system for the given file type. Many file types like different image formats can be previewed with the bundled plugins in OS X and HTML is even rendered in the Quick Look preview panel.

Open Web URL

Open the corresponding web address of a file selected in Cyberduck with your default web browser. For this feature to work, you have to specify a reasonable default path in your bookmark (e.g. /home/dkocher/public_html/) which must be the directory accessed by the web server as your document root. Using an Apache webserver, this is the DocumentRoot directive. Also in the bookmark setting, you can edit the Web URL which allows you to enter the HTTP URL of the webserver using a different hostname. The Open Web URL can be found in the File Menu and as an optional toolbar item in the browser window.

Why isn't there a local file viewer/two pane interface?

That's what Finder.app is for. Use drag and drop (eventually together with Exposé) or Menu File → Upload instead You can also copy files in the Finder.app and then paste them in Cyberduck using Menu Edit → Paste from Finder.

Print browser folder listing

Use the File → Print option where you can open a PDF from the browser listing or print it.

Attachments (7)

Download all attachments as: .zip