Cyberduck Mountain Duck CLI

Version 32 (modified by dkocher, on Dec 18, 2010 at 12:07:55 PM) (diff)

--

Cyberduck Help / Howto / Browser

List and Outline View

Select View → as List or View → as Outline for expandable folders. You can expand and disclose folders using the arrow keys and display the content of the selected/parent folder using Command Down/Up Arrow.

Spring-loaded folders

Spring-loaded folders are a feature that allow you to move a file or even another folder, into a folder deeply nested within several other folders using drag and drop. To enable, choose Preferences → Browser → Use spring-loaded folders when dragging files and adjust the delay for the folder to expand when hovering over with the mouse. Note that spring-loaded folders are only supported in outline view.

Filter

Use the search field (Command-/) to filer files by name. Only files that match the search string are displayed in the browser. Search is case insensitive.

Sorting

You can sort the file listing by clicking the table column header. Choose View → Column to add more headers such as Kind to allow sorting by file type including folders appearing first in the list.

No local file browser

Why isn't there a local file viewer/two pane interface? That's what Finder.app is for. Use drag and drop (eventually together with Exposé) or Menu File → Upload instead You can also copy files in the Finder.app and then paste them in Cyberduck using Menu Edit → Paste from Finder.

Working with files and folders

Create new folder or file

Use File → New Folder... or File → New File... to create a new folder or file on the server.

Move or duplicate files and folders

You can move files in the browser as you would in the Finder.app. Use the alt modifier key to duplicate files. If connected to the same server, you can also move files between different browser windows.

source:trunk/www/help/images/move.png

The following protocols allow duplicating files on the server without downloading and uploading:

Copy files and folders to different server

You can copy files between arbitary servers when connected to with two open browser windows. Drag files from one browser to the other to transfer files between servers.

Copy files between servers

Rename a file or folder

Select the file in the browser and press the return or Enter key. Type the new name and press return again to exit the editing mode. You can also rename files by choosing File → Info or press the Get Info toolbar button. Simply enter the new name in the very top field. The field must loose focus (e.g. by hitting Enter or Tab) to commit the filename change.

source:trunk/www/help/images/rename.png

Info Window

Select the file in the browser and choose File → Info to display detailed attributes of a file in a tool window. It allows to change permissions, manage content distributions for cloud services and settings specific to the Amazon S3 service.

QuickLook

You can toggle Quick Look in a Cyberduck browser for any file using Space Bar. A preview is rendered depending on a Quick Look Plugin available on your system for the given file type. Many file types like different image formats can be previewed with the bundled plugins in OS X and HTML is even rendered in the Quick Look preview panel.

Open Web URL

See Web URL configuration?.

Print browser folder listing

Use the File → Print option where you can open a PDF from the browser listing or print it.

Problems

Special characters such as Umlaute

If characters aren't displayed correctly in the browser, try to change the character encoding used. See View → Text Encoding. Try UTF-8 (the default), ISO-8859-1 and Windows-1252.

The folder size isn't displayed correctly

This is not the size of its content but the size of the folder itself. Use File → Info to calculate the size recursively of all contained files.

Preferences

General → Browser → Save Workspace

Restore browser sessions that were left open when the application was last quit.

General → Browser → Open new browser window on startup

Open new browser window after application launch.

Browser → General → Show Hidden Files

Display files in the browser that start with . and previous revisions (S3). Use View → Show Hidden Files to toggle the mode of a current browser window.

Browser → General → Info window always shows current selection

use only one Info window which updates with the selection change in the browser. If unchecked, open multiple Info windows to compare files.

Attachments (7)

Download all attachments as: .zip

swiss made software