Cyberduck Mountain Duck CLI

Version 36 (modified by dkocher, on Jan 7, 2011 at 10:16:39 PM) (diff)

--

Cyberduck Help / Howto / Opening Connections

Supported protocols

A plethora of protocols is supported to connect to just about any server you want.

Toolbar button

Click the New Connection toolbar button or File → Open Connection.... If you want to open a connection in a new browser window, choose File → New Browser first.

source:trunk/www/help/images/connection.png

Quick Connect

Type in the name of the server directly in to the Quick Connect field in the toolbar. The text field will autocomplete from bookmarked hosts. You can enter a string in the format user@host, i.e. user@example.net, or a fully qualified URL such as ftp://mirror.switch.ch/mirror/.

source:trunk/www/help/images/quick.png

If you enter just the hostname, the default protocol as configured in Preferences → General → Connection will be used.

Bookmarks

Select View → Toggle Bookmarks and double click a bookmark to connect. If you want to bookmark a connection already open, choose Bookmark → New Bookmark and it will add a new bookmark with the current connection settings.

History

Select a bookmark from the menu Bookmark → History.

source:trunk/www/help/images/history.png

Bonjour discovered services

Servers in the local network are most likely to appear in the menu Bookmark → Bonjour.

Opening connections from Finder.app

Bookmark File

Double click a Cyberduck .duck bookmark file in the Finder.

source:trunk/www/help/images/bookmark_file.png

Internet Location File

Double click a Internet Location File in the Finder.app. Cyberduck must be configured as the default protocol handler for the given protocol of the URL.

source:trunk/www/help/images/inetloc.png

Use Spotlight

Application launchers

  • Quickilver. Quicksilver is a launcher application. Open the Quicksilver Preferences and install the Cyberduck Module. Then when Cyberduck is selected in Quicksilver use the right-arrow key to access bookmarks wthin Quicksilver.
  • LaunchBar. Indexing rule for Cyberduck.

From thirdparty application

Drag an URL from any thirdparty application to a browser window.

  • Drag an URL (e.g. from Safari) to the browser list or outline view to open a new connection.
  • Drag an URL to the bookmarks to create a new bookmark.

Problems Connecting

I get an error IO Error: Broken pipe

There was a problem with the unerlying network stream either because the connection was too slow or the server wouldn't give a response anymore. Often this is caused when you run out of quota on the server - meaning that your user account is not allowed to use any more harddisk space.

I get an error IO Error: Read Timed Out

When attempting to open a connection, there is either a firewall blocking requests, or no server is listening at the given address and port. If you get this error while already connected to the server, the network connection to the server is too slow or has a too high latency. You can try to increase the connection timout in Preferences → Connection → Timeouts.

Transcript

Useful to look at issues is the transcript written to the log drawer. Choose View → Toggle Log Drawer. All commands written to and read from the server are logged there if the drawer is open.

Preferences

Connection → Text Encoding

The text encoding selected is used to decode the filenames in a directory listing sent by the server. It is important this matches the text encoding used by the server to encode the characters as otherwise characters not in the ASCII range (such as German Umlaute) are not displayed correctly. UTF-8 (the default), ISO-8859-1 and Windows-1252 are the most common. You can also change the text encoding per browser using View → Text Encoding.

Connection → Timeouts

You might need to adjust the timeout to wait for an answer from the server. The default is set to 30 seconds.

Connection → Repeat failed networking tasks

Failed transfers due to network connection issues such as a low latency can be choosen to be repeated with a configurable number of retries.

Connection → Proxies

The following proxy settings in System Preferences are supported. Choose Cyberduck → Preferences → Connection → Use system proxy settings. No additional configuration needed.

Default protocol handler

You can set Cyberduck or a third party application as the default application (protocol handler) for FTP and SFTP in Preferences → FTP and Preferences → SFTP respectively. When you click URLs in another application like your web browser, this application is opened to open the URL instead.

Attachments (7)

Download all attachments as: .zip

swiss made software