Cyberduck Mountain Duck CLI

Version 4 (modified by rudo.ba, on Nov 30, 2010 at 11:03:59 PM) (diff)

--

Pomocník pre Cyberduck / Ako na to? / Prehliadač

Stručný a rozšírený zoznam

Vyberte v ponuke Zobrazenie → Stručný zoznam alebo Zobrazenie → Rozšírený zoznam pre načítateľné priečinky. Priečinky možno otvoriť a zobraziť použitím kláves so šípkami a zobraziť obsah vybraného/rodičovského priečinka použitím Command + šípka dole/hore.

Pružne načítavané priečinky

Pružne načítavané priečinky umožňujú presúvať súbor (prípadne celý priečinok) do vnúra cieľového priečinka vnoreného hlboko vo viacerých iných priečinkoch, metódou ťahaj a pusti. Túto funkciu možno zapnúť v paneli Predvoľby → Prehliadač → Pri ťahaní súborov pružne načítavať priečinky, kde možno ďalej nastaviť aj oneskorenie načítania priečinka pri podržaní myši nad ním. Pozor, pružne načítavané priečinky sú podporované len pri zobrazení rozšíreného zoznamu.

Filtrovanie

Pre filtrovanie súborov podľa názvu použite vyhľadávacie pole (Command-/). V okne prehliadača sa zobrazia len súbory vyhovujúce hľadanému výrazu. Vyhľadávanie nerozlišuje veľké a malé písmená.

Chýbajúci prehliadač lokálnych súborov

Prečo Cyberduck neobsahuje prehliadač lokálnych súborov (dvojpanelové rozhranie)? Na to slúži Finder. Použite metódu ťahaj a pusti (prípadne v kombinácii s Exposé), alebo príkaz v ponuke Súbor → Odoslať… Tiež možno skopírovať súbory z Findera a následne ich vložiť do Cyberducku príkazom v ponuke Úpravy → Vložiť z Findera.

Práca so súbormi a priečinkami

Vytvorenie nového priečinka alebo súboru

Pre vytvorenie nového priečinka alebo súboru na vzdialenom serveri použite príkaz v ponuke Súbor → Nový priečinok… alebo Súbor → Nový súbor….

Presunutie alebo duplikovanie súborov a priečinkov

Súbory možno v prehliadači presúvať rovnako ako vo Finderi. Pre duplikovanie súborov použite modifikačný kláves alt. Súbory tiež možno presúvať medzi rôznymi oknami prehliadača pripojenými k rovnakému serveru.

source:trunk/www/help/images/move.png

Nasledovné protokoly umožňujú duplikovanie súborov na serveri bez nutnosti prevzatia a následného odoslania:

Kopírovanie súborov a priečinkov na iný server

Súbory možno kopírovať medzi ľubovoľnými servermi pripojenými k dvom otvoreným oknám prehliadača. Pre prevzatie a odoslanie presúvajte súbory medzi oboma oknami.

Premenovanie súboru alebo priečinka

Označte súbor v prehliadači a stlačte kláves return alebo enter. Zapíšte nový názov a pre ukončenie režimu editovania znovu stlačte reuturn. Súbor možno premenovať aj výberom ponuky Súbor → Informácie alebo tlačidlom Informácie v riadku nástrojov. Jednoducho zdajte nový názov do najvrchnejšieho textového poľa. Zmena sa uplatní po opustení poľa (napríklad stlačením klávesov enter alebo tabulátor).

source:trunk/www/help/images/rename.png

Okno Informácie

Pre zobrazenie detailných vlastností súboru v pomocnom okne, vyberte ponuku Súbor → Informácie. Tu možno meniť oprávnenia, spravovať distribúcie obsahu v Cloud službách a upravovať nastavenia špecifické pre službu Amazon S3.

QuickLook

Každý súbor v prehliadači Cyberducku sa stlačením klávesu medzerník možno pokúsiť zobraziť pomocou Quick Look. V závislosti na dostupnosti doplnku nástroja Quick Look pre daný typ súboru vo vašom systéme dôjde k vykresleniu náhľadu obsahu súboru. Mnoho typov súborov – napríklad rôzne obrazové formáty možno zobraziť pomocou zabudovaných doplnkov v OS X, rovnako tak HTML obsah bude zobrazený v náhľadovom okne nástroja Quick Look.

http://trac.cyberduck.ch/raw-attachment/wiki/help/en/howto/browser/quicklook.png

Otvorenie webového umiestnenia

Viď nastavenie webového URL.

Vytlačenie výpisu priečinkov prehliadača

Pre vytlačenie (alebo vytvorenie PDF) výpisu priečinkov prehliadača použite príkaz Súbor → Tlačiť.

Problémy

Zvláštne znaky (s diakritikou)

Ak sa znaky v prehliadači nezobrazujú správne, skúste zmeniť ich kódovanie. Viď Zobrazenie → Znaková sada. Vyskúšajte UTF-8 (predvolené), ISO-8859-2 a Windows-1250.

Veľkosť priečinka sa nezobrazuje správne

Nezobrazuje sa veľkosť jeho obsahu, ale veľkosť samotného priečinka. Pre rekurzívny výpočet veľkosti všetkých obsiahnutých súborov použite príkaz Súbor → Informácie.

swiss made software