Cyberduck Mountain Duck CLI

Version 6 (modified by rudo.ba, on Dec 5, 2010 at 6:18:13 PM) (diff)

--

Pomocník pre Cyberduck / Ako na to? / Úprava súborov

Úprava súboru v externom editore

Vzdialený súbor možno upravovať rovnako ako lokálny súbor: kliknutím na tlačidlo Upraviť v riadku nástrojov, alebo zvolením Súbor → Upraviť v editore. Súbor bude prevzatý do používateľovho dočasného priečinka a otvorený predvoleným editorom. Predvolený editor možno nastaviť v Cyberduck → Predvoľby… → Editor. Súbor bude odoslaný na server vždy, keď v editore zvolíte Súbor → Uložiť. Ak dokument zavriete bez uloženia, súbor na serveri nebude zmenený.

source:trunk/www/help/images/edit.png

Výber editora pre konkrétne typy súborov

Predvolený editor je vybraný podľa predvolenej aplikácie pre daný typ súboru nastavenej vo Finderi (viď File → Info pre daný typ súboru vo Finderi). Ak v systéme predvolená aplikácia nie je podporovaná Cyberduckom, použije sa aplikácia nastavená v predvoľbách Cyberducku.

Označením možnosti Vždy použiť predvolený editor v Predvoľby → Editor možno vynútiť použitie (v Cyberducku) nastaveného editora bez ohľadu na typ súboru.

Ak nie je dostupný žiadny externý editor

Ak sa v ponuke Súbor → Upraviť v editore nezobrazuje žiadny editor (jedinou položkou v podmenu je Nie je dostupný žiadny externý editor), je potrebné obnoviť OS X databázu LaunchServices pomocou aplikácie Terminal:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister \ -kill -r -domain local -domain system -domain user

Prípadne, aplikácia MainMenu poskytuje pre tento príkaz grafické rozhranie, viď Rebuild → Rebuild Launch Services.

swiss made software