Cyberduck Mountain Duck CLI

#9368 closed defect (fixed)

Transfer fails with 421 Too many connections (8) from this IP

Reported by: jimweber Owned by: dkocher
Priority: normal Milestone: 5.0
Component: ftp Version: 4.8.3
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

When trying to upload files via FTP, I can establish a connection but when I try to upload the Drupal files the connection is dropped. Contacted my hosting service, MacHighway, about this. They indicated that they had made some changes to server, so I deleted the bookmark and created a brand new connection. In their testing they were able to transfer using FileZilla, which I also ended up using to update all my Drupal sites. I much prefer Cyberduck. Please advise.

Attachments (2)

Screen Shot 2016-03-15 at 11.10.00 AM.png (228.3 KB) - added by jimweber on Mar 15, 2016 at 6:57:01 PM.
error dialogue
log-2016-3-16.rtf (344.0 KB) - added by jimweber on Mar 20, 2016 at 7:19:58 PM.
log file

Download all attachments as: .zip

Change History (22)

Changed on Mar 15, 2016 at 6:57:01 PM by jimweber

error dialogue

comment:1 Changed on Mar 15, 2016 at 8:11:33 PM by dkocher

Please post the transcript from the log drawer of the Transfers window (Choose ⌘-L).

comment:2 Changed on Mar 15, 2016 at 8:11:58 PM by dkocher

  • Component changed from core to ftp
  • Owner set to dkocher
  • Summary changed from FTP connection dropped to Transfer fails with 421 response

comment:3 follow-ups: Changed on Mar 16, 2016 at 2:04:35 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

The provider should check the support for data connections using PASV.

comment:4 in reply to: ↑ 3 Changed on Mar 16, 2016 at 6:43:13 PM by jimweber

Replying to dkocher:

The provider should check the support for data connections using PASV.

Contacted provider, MacHighway, and they made sure that PASV mode was enabled on their server. The same problem persists – I am able to connect but when I try to upload files using FTP, there server drops the connection.

Since I can use FileZilla to upload files, it would seem that the issue is with CyberDuck. Please advise.

comment:5 in reply to: ↑ 3 Changed on Mar 18, 2016 at 7:56:18 PM by jimweber

  • Resolution thirdparty deleted
  • Status changed from closed to reopened

Replying to dkocher:

The provider should check the support for data connections using PASV.

Contacted provider, MacHighway, and they made sure that PASV mode was enabled on their server. The same problem persists – I am able to connect but when I try to upload files using FTP, there server drops the connection.

Since I can use FileZilla to upload files, it would seem that the issue is with CyberDuck. Please advise.

comment:6 Changed on Mar 18, 2016 at 7:56:53 PM by jimweber

Contacted provider, MacHighway, and they made sure that PASV mode was enabled on their server. The same problem persists – I am able to connect but when I try to upload files using FTP, there server drops the connection.

Since I can use FileZilla to upload files, it would seem that the issue is with CyberDuck. Please advise.

comment:7 follow-up: Changed on Mar 19, 2016 at 7:33:03 PM by dkocher

Please post the transcript from the log drawer of the Transfers window. Choose ⌘-L on Mac or right-click the toolbar from the Transfers window and choose Log on Windows

Changed on Mar 20, 2016 at 7:19:58 PM by jimweber

log file

comment:8 in reply to: ↑ 7 Changed on Mar 20, 2016 at 7:21:15 PM by jimweber

Replying to dkocher:

Please post the transcript from the log drawer of the Transfers window. Choose ⌘-L on Mac or right-click the toolbar from the Transfers window and choose Log on Windows

Could not post log here as it was too many characters. So I attached it as a rtf file.

Last edited on Mar 20, 2016 at 7:22:23 PM by jimweber (previous) (diff)

comment:9 Changed on Mar 21, 2016 at 8:11:22 AM by dkocher

  • Milestone set to 5.0
  • Summary changed from Transfer fails with 421 response to Transfer fails with 421 Too many connections (8) from this IP

comment:10 Changed on Mar 21, 2016 at 8:15:37 AM by dkocher

Please limit the number of connections allowed for file transfers or disable the use of multiple connections for file transfers in Preferences → Transfers → Transfer Files by choosing Open new connection.

comment:11 Changed on Apr 5, 2016 at 2:04:21 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:12 Changed on Apr 15, 2016 at 12:28:17 PM by dkocher

#9433 closed as duplicate.

comment:13 Changed on Apr 15, 2016 at 12:28:39 PM by dkocher

#9464 closed as duplicate.

comment:14 Changed on Apr 15, 2016 at 12:57:51 PM by dkocher

  • Milestone changed from 5.0 to 4.9.1

comment:15 Changed on Apr 15, 2016 at 12:57:57 PM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:16 Changed on Apr 15, 2016 at 1:16:19 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

We now retry 421 failures with a 1s delay between retries. In r20173.

comment:17 follow-up: Changed on May 4, 2016 at 1:35:44 PM by dkocher

  • Milestone changed from 4.9.1 to 5.0
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:18 in reply to: ↑ 17 ; follow-up: Changed on May 4, 2016 at 9:04:02 PM by jimweber

Replying to dkocher: The problem had been resolved. Why did you reopen? Is there something I need to do?

comment:19 in reply to: ↑ 18 Changed on May 8, 2016 at 3:16:57 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to jimweber:

Replying to dkocher: The problem had been resolved. Why did you reopen? Is there something I need to do?

Revised test and fix in r20370.

comment:20 Changed on May 24, 2016 at 2:01:13 PM by dkocher

#9499 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software